Monitoring
We have been informed the security filters have been updated to unblock video calling functionality. We're monitoring performance.
Investigating
We have confirmed the list of vendors blocking connectivity and are working with them to restore access.
Investigating
Some customers may experience disconnects, drops or inability to start video calls due to security filters blocking a third-party provider.